You are asked to ensure that the first and last names of people begin with a capital letter in their passports. For example,
alison heck
should be capitalised correctly as Alison Heck
.Given a full name, your task is to capitalize the name appropriately.
Input Format
A single line of input containing the full name, .
Constraints
- The string consists of alphanumeric characters and spaces.
Note: in a word only the first character is capitalized. Example 12abc when capitalized remains 12abc.
Output Format
Print the capitalized string, .
Sample Input
chris alan
Sample Output
Chris Alan
Program:
def solve(s): s2="" numlist=[0,1,2,3,4,5,6,7,8,9] list1=list(s) if list1[0] not in numlist: list1[0]=list1[0].upper() for i in range(0,len(list1)): if list1[i]==' ': list1[i+1]=list1[i+1].upper() return (s2.join(list1))
if __name__ == '__main__': fptr = open(os.environ['OUTPUT_PATH'], 'w')
s = input()
result = solve(s)
fptr.write(result + '\n')
fptr.close()
Output:
Post a Comment