Given a time in -hour AM/PM format, convert it to military (24-hour) time.
Note: - 12:00:00AM on a 12-hour clock is 00:00:00 on a 24-hour clock.
- 12:00:00PM on a 12-hour clock is 12:00:00 on a 24-hour clock.
Example
Return '12:01:00'.
Return '00:01:00'.
Function Description
Complete the timeConversion function in the editor below. It should return a new string representing the input time in 24 hour format.
timeConversion has the following parameter(s):
- string s: a time in hour format
Returns
- string: the time in hour format
Input Format
A single string that represents a time in -hour clock format (i.e.: or ).
Constraints
- All input times are valid
Sample Input 0
07:05:45PM
Sample Output 0
19:05:45
Program:
#!/bin/python3
import osimport sys
## Complete the timeConversion function below.#def timeConversion(s):
list1=list(s) n=len(list1) s1="" if (list1[n-2]=='A') & (list1[n-1]=='M'): if (list1[0]=='1') & (list1[1]=='2'): list1[0]=str(0) list1[1]=str(0) list1.pop(len(list1)-1) list1.pop(len(list1)-1) for item in list1: s1+=item return(s1) else: list1.pop(len(list1)-1) list1.pop(len(list1)-1) for item in list1: s1+=item return(s1) else: if (list1[0]=='1') & (list1[1]=='2'): list1.pop(len(list1)-1) list1.pop(len(list1)-1) for item in list1: s1+=item return(s1) else: s2="" s2+=list1[0] s2+=list1[1] k=int(s2)+12 list1[0]=str(k) list1.pop(1) list1.pop(len(list1)-1) list1.pop(len(list1)-1) for item in list1: s1+=item return s1
if __name__ == '__main__': f = open(os.environ['OUTPUT_PATH'], 'w')
s = input()
result = timeConversion(s)
f.write(result + '\n')
f.close()
Post a Comment