- Mini-Max Sum

 


Given five positive integers, find the minimum and maximum values that can be calculated by summing exactly four of the five integers. Then print the respective minimum and maximum values as a single line of two space-separated long integers.

Example

The minimum sum is  and the maximum sum is . The function prints

16 24

Function Description

Complete the miniMaxSum function in the editor below.

miniMaxSum has the following parameter(s):

  • arr: an array of  integers

Print

Print two space-separated integers on one line: the minimum sum and the maximum sum of  of  elements.

Input Format

A single line of five space-separated integers.

Constraints

Output Format

Print two space-separated long integers denoting the respective minimum and maximum values that can be calculated by summing exactly four of the five integers. (The output can be greater than a 32 bit integer.)

Sample Input

1 2 3 4 5

Sample Output

10 14

Explanation

The numbers are , and . Calculate the following sums using four of the five integers:

  1. Sum everything except , the sum is .
  2. Sum everything except , the sum is .
  3. Sum everything except , the sum is .
  4. Sum everything except , the sum is .
  5. Sum everything except , the sum is .

Hints: Beware of integer overflow! Use 64-bit Integer.


Program:

#!/bin/python3

import math
import os
import random
import re
import sys

# Complete the miniMaxSum function below.
def miniMaxSum(arr):
    min_elem=min(arr)
    max_elem=max(arr)
    
    min_sum=0
    max_sum=0
    
    for item in arr:
        if item!=min_elem:
            max_sum+=item
        if item!=max_elem:
            min_sum+=item
        if min_elem==max_elem:
            min_elem=4*min_elem
            max_elem=4*max_elem
    print(min_sum, max_sum)

if __name__ == '__main__':
    arr = list(map(intinput().rstrip().split()))

    miniMaxSum(arr)

Output:
Compiler Message
Success
Input (stdin)
  • 1 2 3 4 5
Expected Output
  • 10 14

Post a Comment

Previous Post Next Post