- Staircase

 

Staircase detail

This is a staircase of size :

   #
  ##
 ###
####

Its base and height are both equal to . It is drawn using # symbols and spaces. The last line is not preceded by any spaces.

Write a program that prints a staircase of size .

Function Description

Complete the staircase function in the editor below.

staircase has the following parameter(s):

  • int n: an integer

Print

Print a staircase as described above.

Input Format

A single integer, , denoting the size of the staircase.

Constraints

 .

Output Format

Print a staircase of size  using # symbols and spaces.

Note: The last line must have  spaces in it.

Sample Input

6 

Sample Output

     #
    ##
   ###
  ####
 #####
######

Explanation

The staircase is right-aligned, composed of # symbols and spaces, and has a height and width of .


Program:

import math
import os
import random
import re
import sys

# Complete the staircase function below.
def staircase(n):
    for i in range(1,n+1):
        for j in range(0,n-i):
            print(" ",end="")
        for k in range(0,n-(n-i)):
            print("#",end="")
        print()
            
            

if __name__ == '__main__':
    n = int(input())

    staircase(n)

Output:
Input (stdin)
  • 6
Your Output (stdout)
  •      #
  •     ##
  •    ###
  •   ####
  •  #####
  • ######
Expected Output
  •      #
  •     ##
  •    ###
  •   ####
  •  #####
  • ######

Post a Comment

Previous Post Next Post